1. Download kiwix.exe and double-click on the file to open it.

2. The first time you open Kiwix, a prompt should appear to visit the library. If it does not (or if you want to see what's available at any time), go to File > Browse library. Pick the language you want and then download the corresponding ZIM file.

3. Once the file is downloaded, Kiwix should offer you to open it. If it does not (or if you want to open an older file), click on "My library" in the top-left corner of the app's window.

1. Download kiwix.dmg. Double-click on the file and drag/drop it into the application folder. If you try to run Kiwix immediately, macOS will tell you that "Kiwix is damaged". It is normal: that's the default behaviour for apps that do not come directly from iTunes.

2. Open a Terminal (simply search for "terminal" in the macOS Spotlight search bar) and type sudo bash to grant you the appropriate install privilege.

3. Enter the following: xattr -cr /Applications/Kiwix.app

4. Run Kiwix.

5. The first time you open Kiwix, a prompt should appear to visit the library. If it does not (or if you want to see what's available at any time), go to File > Browse library. Pick the language you want and then download the corresponding ZIM file.



6. Once the file is downloaded, Kiwix should offer you to open it. If it does not (or if you want to open an older file), click on library icon  in the top-left corner of the app's window.

Navigation keys and buttons

Browsing Kiwix content is similar to using a web browser, so you can easily navigate from a page (which could be a document or an article) to another page. Clicking on the Home icon  will take you to your current file's homepage. If you haven't installed any ZIM file yet, you will see the Help page as the homepage and it means there is no content to display. 

Just like your web browser, you can return to the previous page by clicking on the Back arrow icon  and go to the next page by clicking on the Forward arrow icon  in the toolbar. To open the New Tab page, click on the Open a new tab icon (+) next the last tab at the top of the window or press Ctrl+T (⌘-T on Mac). To close a tab, use the close button (x) on the right side of each tab you want to close or the keyboard shortcut Ctrl+W (⌘-W on Mac). You can open the links of a page in a new tab, by pressing Ctrl on your keyboard or right clicking on the link and then choosing "Open link in new Tab".

You can print the Kiwix pages or even export and share them. There are three options available:

1. To print a page you are viewing in Kiwix, click on the Print icon  in the toolbar or press Ctrl+P (⌘-P on Mac). This option is also available in File menu. You will be able to preview the page and adjust basic printer and page settings, before printing. Make sure your computer is connected to the printer and that the printer is also turned on.

2. To export a page to PDF format, go to File > Print as PDF menu item or just press Ctrl+Shift+D (⌘-Shift-D on Mac). It will convert the page into a PDF file which can be used to print or read the document later. Note that the output has been prepared for printing and the internal links will be removed from the page.

3.To save the page as an HTML or text file, go to File > Save page as... menu item or just press Ctrl+S (⌘-S on Mac). Although it is not appropriate for sharing, the HTML format will keep the same formatting and links of the page.

Printing and Exporting

Creating and using bookmarks

You can use Kiwix bookmarks to easily save the pages you would like to revisit. Bookmarks are organized in sets which is a list (or group) of bookmarks that has been put together. You can easily import/export a complete set of bookmarks, which is saved as a regular file on your computer, and you may wish to share a list of pages then, e.g. with your students.

Clicking on the Bookmarks icon Bookmarks24.png in the toolbar will show you the Bookmarks panel on the left side of the application. To create a new set, click on the Create new Bookmark Set icon New24.png and then choose a path on your computer and type a name. It will be saved as a .XML file and each time you add or delete a bookmark to the set, this file will be updated. You can share this file with someone or somewhere else to import or backup. If you have a Bookmark file and want to import it to your Kiwix, click on the Import Bookmark Set icon Open24.png in top of the panel and then select the .XML file from your computer.

You can add the current page to your bookmark set by clicking on the Mark this page icon Add24.png or use the keyboard shortcut Ctrl+D (⌘-D on Mac). It will add to the Bookmark list and you can also write some notes for it in the bottom of the panel, Bookmark notes. Selecting each item of the list will navigate you to that page, and you may want to remove that item by clicking on the Unmark selected icon Remove24.png. You can switch between your opened sets (default one and those you imported) using the combo list of opened bookmark sets below the panel toolbar. Once you close Kiwix, all your sets will be closed and you will need to import them again the next time.

Use the find bar to locate a specific word or phrase in a page. To do so, click on the Find in text icon Find-article24.png in the toolbar or choose Edit > Search in page from menu bar. You can also use the keyboard shortcut Ctrl+F (⌘-F on Mac) to quickly open the Find bar. Kiwix automatically finds the page as you type, highlighting possible matches in green; you can also see where all the matches are located on a page (in pink) by tapping on the Highlight all button in the Find bar. Switch between the search results using Next and Previous in the find bar and also choose Match case if you want a case-sensitive search.

Kiwix also supports copy-pasting. To do this, select the text using the mouse and then choose Edit > Copy16.png Copy or just press Ctrl+C (⌘-C on Mac) from your keyboard. You can also right-click on the text and choose "Copy" to copy the text or "Search for" to search the text in the ZIM file. If you want to select the whole page, choose Edit > Select-all16.png Select all or press Ctrl+A (⌘-A on Mac) from your keyboard. You can also right-click anywhere in the page and choose "Select all".

Search and Copy text

More options

You can change the language settings of the application by going to Display > Language in the menu bar and choosing your desired language. You can also change the skin appearance by going to Display > Skin. By choosing Display > Inverted colors or pressing Ctrl+I (⌘-I on Mac), the colors of the page will be inverted, e.g. the black text will be white and the white background will be black.

Like the sidebar of Wikipedia, there is an option named Select-all16.png Random article in the Tools menu, which will show a random article from the current file. Another option is Purge-history16.png Purge history which will clear the history of the pages you visited.

If you have a local network and want to share Kiwix with other clients on the network, go to Tools > Server, click on the Start button after selecting the port and then click on Load. Afterward, you will have the same Kiwix with less features in your network (simply in your web browser). Additional information can also be found on Kiwix-serve.