1. Téléchargez kiwix.exe et double-cliquez sur le fichier pour ouvrir le programme.

2. A la première ouverture de Kiwix, celui-ci devrait vous proposer de visiter la bibliothèque pour y choisir des contenus. Si ce n'est pas le cas (ou si vous voulez voir ce qui est disponible à tout moment), allez sur Fichier > Parcourir la bibliothèque, choisissez le contenu que vous voulez et téléchargez le fichier ZIM correspondant.

3. Une fois ce fichier téléchargé, Kiwix vous proposera de l'ouvrir. Si ce n'est pas le cas (ou si vous voulez ouvrir un autre fichier), cliquez sur l'icône  dans le coin supérieur gauche de la fenêtre.

1. Téléchargez kiwix.dmg. Double-cliquez sur le fichier et tirez-déposez le dans le dossier application (comme pour toute installation standard). Si vous essayez d'ouvrir Kiwix directement après cette installation, macOS vous indiquera "Kiwix est endommagé". Cela est normal (c'est une mesure de sécurité contre les programmes qui ne viennent pas d'iTunes). Kiwix n'est pas endommagé.

2. Ouvrez le Terminal (cherchez "terminal" dans la barre de recherche macOS Spotlight) et tapez sudo bash pour obtenir les droits complets d'installation.

3. Tapez les instructions suivantes: xattr -cr /Applications/Kiwix.app

4. Lancez Kiwix.

5. A la première utilisation de Kiwix, celui-ci vous proposera de visiter la bibliothèque de contenus disponibles. S'il ne le fait pas (ou si vous souhaitez voir ce qu'il y a n'importe quand), allez sur Fichier > Parcourir la bibliothèque. Choisissez le contenu qui vous intéresse et commencez le téléchargement.



6. Une fois le téléchargement terminé, Kiwix vous proposera de consulter ce fichier. S'il ne le fait pas (ou si vous voulez consulter un autre contenu), cliquez sur l'icône de bibliothèque  dans le coin supérieur gauche de la fenêtre.

Navigation

La manière de parcourir le contenu de Kiwix est similaire à un navigateur web. Cliquez sur l’icône Page d'accueil  si vous voulez vous rendre sur la page d'accueil de votre fichier ZIM actuel. Si vous n'avez pas encore installé un fichier ZIM, vous verrez la page d'aide sur la page d'accueil et cela signifie qu'il n'y a pas de contenu à afficher.

Tout comme dans votre navigateur, vous pouvez revenir à la page précédente en cliquant la flèche gauche   et avancer à la suivante en cliquant sur la flèche droite  dans la barre d'outils. Pour ouvrir un nouvel onglet, cliquez sur Ouvrir (+) à côté du dernier onglet ouvert, ou appuyez sur Ctrl T (⌘T sur Mac). Pour fermer un onglet, utilisez le bouton de fermeture (x) sur le côté droit ou appuyez sur Ctrl et W (⌘-W sur Mac). Pour ouvrir un lien dans un nouvel onglet, appuyez sur Ctrl au moment de cliquer sur ce lien, ou faîtes un clic droit et choisissez "Ouvrir dans un nouvel onglet".

Vous pouvez imprimer et même exporter et partager des pages de Kiwix. Il y a pour ce faire plusieurs méthodes:

1. Pour imprimer un epage, cliquez sur l'icône d'impression  dans la barre d'outils ou pressez Ctrl P (⌘-P sur Mac). Cette option est également disponible dans le menu Fichier. Vous pourrez prévisualiser la page et modifier les réglages avant de lancer l'impression. Assurez-vous bien sûr que l'imprimante est branchée et en marche.

2. Pour exporter un page au format PDF, allez sur Fichier > Créer un PDF ou pressez simplement Ctrl Shift D (⌘-Shift-D sur Mac). Kiwix convertira la page en un document PDF que vous pourrez imprimer ou consulter plus tard. Veuillez noter que le fichier ainsi généré n'aura plus de liens dans le corps du texte.

3.Pour effectuer une sauvegarde au format HTML ou text, allez sur Fichier > Enregistrer la page sous... ou pressez simplement Ctrl S (⌘-S sur Mac). Même si ce n'est pas très pratique pour le partage, le format HTML gardera les liens et le format d'origine.

Imprimer et Exporter

Créer et utiliser des signets

Vous pouvez marquer des pages d'intérêt sur Kiwix à l'aide de signets (ou marque-pages). Ceux-ci sont organisés sous formes de groupes (ou listes) que vous pouvez également exporter et partager (si par exemple vous voulez donner une liste de pages à lire à vos étudiants).

En cliquant sur l'icône marque-pages  Bookmarks24.png dans la barre supérieure vous ferez apparaître la fenêtre de gestion des signets. Pour créer un nouveau groupe, cliquez sur l'icône Créer un nouveau jeu de marque-pages  New24.png et donnez lui un nom (et souvenez-vous de l'endroit où vous désirez le conserver). Vous aurez alors créé un fichier XML qui sera mis à jour à chaque fois qu'un signet sera ajouté ou enlevé, et vous pourrez partager ce fichier avec quelqu'un qui pourra lui-même l'importer sur sa version de Kiwix. Pour ce faire, cliquez sur Importer un marque-pages Open24.png  au sommet de la fenêtre et choisissez le fichier XML que l'on vous aura donné.

Vous pouvez ajouter une page à vos signets en cliquant sur l'icône Marquer cette page Add24.png ou en utilisant le raccourci Ctrl+D (⌘-D sur Mac) de votre clavier. Le marque page sera ajouté à la liste et vous pourrez même y ajouter une note. En sélectionnant un item de la liste de signets et cliquant sur Retirer Remove24.png, celui-ci sera effacé. Si vous avez plusieurs listes de signets, vous pouvez passer de l'une à l'autre en cliquant sur le menu déroulant qui contient le nom de la liste actuelle (sous le (+) de la fenêtre de signets). Attention, à la fermeture de Kiwix tous vos sets sont fermés et vous devrez les réimporter à la prochaine ouverture.

La barre de recherche vous permet de trouver un mot ou phrase dans une page. Pour ce faire, cliquez sur l'icône de recherche  Find-article24.png de la barre d'outils ou aller sur Edition > Chercher dans la page dans le menu. Autre option: le raccourci Ctrl+F (⌘-F sur Mac) de votre clavier. Kiwix cherche au fur et à mesure que vous tapez, surlignant les possibles concordances en vert dans le texte; vous pouvez aussi voir toutes les occurences en cliquant sur Highlight all à droite de la barre de recherche (elles apparaîtront alors en rose). Vous pouvez passer d'un résultat à l'autre en cliquant sur les flèches Haut et Bas à côté de la barre de recherche. Pour respecter la casse (e.g. "Chien" vs. "chien", cliquez sur Match case à droite de la barre.

Kiwix permet aussi la copie de texte. Pour ce faire, sélectionnez le texte à copier puis allez sur Edition > Copy16.png Copier ou pressez simplement Ctrl+C (⌘-C sur Mac) sur votre clavier. Vous pouvez aussi cliquer avec le bouton droit sur le texte surligné et choisir "Copier" ou "Rechercher" pour chercher ce mot ou cette phrase ailleurs dans la page. Pour sélectionner la page entière, allez sur Edition > Select-all16.png Tout sélectionner ou pressez Ctrl+A (⌘-A sur Mac) sur votre clavier. Vous pouvez également cliquer n'importe où avec le bouton droit de votre souris et choisir "Tout sélectionner".

Rechercher et Copier du texte

Autres fonctionnalités

Vous pouvez changer les paramètres de langue du programme en allant sur Affichage > Langue dans le menu et en choisissant le langage que vous voulez utiliser. Vous pouvez également changer l'apparence de Kiwix en allant sur Affichage > Habillage. En cliquant sur Habillage > Couleurs inversées (ou en pressant Ctrl+I (⌘-I sur Mac) sur votre clavier), les couleurs de la page seront inversées (le blanc deviendra noir et le noir deviendra blanc).

Comme sur la barre latérale de Wikipédia, il existe également une fonction Article au hasard dans le menu Outils (ou Ctrl+R⌘-R). Une autre option est de Purge-history16.png Purger l'historique pour effacer la liste des pages que vous avez visitées.

Si vous êtes sur un réseau local et voulez partager l'accès à Kiwix, aller dans Outils > Serveur, cliquez sur le bouton Démarrer puis sur Charger: les utilisateurs pourront alors accéder à Kiwix depuis leur navigateur web. Pour plus d'informations à ce sujet, rendez-vous sur Kiwix-serve.